Back to overview
Degraded

Maintenance

Dec 23 at 09:24am CET
Affected services
Backend website uptime

Resolved
Dec 23 at 01:08pm CET

The maintenance has completed and the service is fully functional again.

Created
Dec 23 at 09:24am CET

We are running necessary upgrades to key infrastructure. Service will be mostly unaffected, but users may experience slight delays when attempting to connect their accounts.